aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 06:13:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 06:13:14 +0000
commit528cbc4a87f6f9fd2686cccd885e8b61ad34c91c (patch)
treed6f2b107fd9be9baebc20152d52f1c6a90de9df0 /target
parent22e1fba31c6cb0190aba2260e628fb420a0ac0f4 (diff)
downloadmaster-187ad058-528cbc4a87f6f9fd2686cccd885e8b61ad34c91c.tar.gz
master-187ad058-528cbc4a87f6f9fd2686cccd885e8b61ad34c91c.tar.bz2
master-187ad058-528cbc4a87f6f9fd2686cccd885e8b61ad34c91c.zip
ar71xx: image: use the board name for temporary mtdpart files
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38149 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c7e36af3d0..0b7c98fd3e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -491,12 +491,12 @@ define Image/Build/UBNT2
$(eval fwsize=$(call mtdpartsize,firmware,$(3)))
$(call Sysupgrade/KRuImage,$(1),$(2),0,$$$$(($(fwsize)-4*64*1024)),64)
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(1)-mtdpart-kernel.bin bs=1024k count=1; \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(1)-mtdpart-rootfs.bin bs=1024k skip=1; \
+ dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-kernel.bin bs=1024k count=1; \
+ dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-rootfs.bin bs=1024k skip=1; \
$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
- -k $(KDIR_TMP)/$(1)-mtdpart-kernel.bin \
- -r $(KDIR_TMP)/$(1)-mtdpart-rootfs.bin \
+ -k $(KDIR_TMP)/$(2)-mtdpart-kernel.bin \
+ -r $(KDIR_TMP)/$(2)-mtdpart-rootfs.bin \
-o $(call factoryname,$(1),$(2)); \
fi
endef