aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-09-27 14:54:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-09-27 14:54:04 +0000
commit4ce9fd34457db66ad031c6f91c6cb993fc3b6bbc (patch)
tree46666859c8595a11950c35b8c4bd53117bab06e7 /target
parent4cda300019396e5ef6bf4495b7626efe9a761f78 (diff)
downloadmaster-187ad058-4ce9fd34457db66ad031c6f91c6cb993fc3b6bbc.tar.gz
master-187ad058-4ce9fd34457db66ad031c6f91c6cb993fc3b6bbc.tar.bz2
master-187ad058-4ce9fd34457db66ad031c6f91c6cb993fc3b6bbc.zip
ar71xx: build firmware image for the TL-MR3420 v1 board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index bad8744751..890e4b28a8 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -5,6 +5,17 @@
# See /LICENSE for more information.
#
+define Profile/TLMR3420V1
+ NAME:=TP-LINK TL-MR3420 v1
+ PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3420V1/Description
+ Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
define Profile/TLWA901NDV1
NAME:=TP-LINK TL-WA901ND v1
PACKAGES:=kmod-ath9k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0c348565ff..42db6e4943 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -531,6 +531,10 @@ define Image/Build/Profile/MZKW300NH
$(call Image/Build/Template/$(fs_64k)/$(1),Planex,mzk-w300nh,board=MZK-W300NH)
endef
+define Image/Build/Profile/TLMR3420V1
+ $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
+endef
+
define Image/Build/Profile/TLWA901NDV1
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v1,board=TL-WA901ND,TL-WA901NDv1)
endef
@@ -619,6 +623,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/PB92,$(1))
$(call Image/Build/Profile/TEW632BRP,$(1))
$(call Image/Build/Profile/TEW652BRP,$(1))
+ $(call Image/Build/Profile/TLMR3420V1,$(1))
$(call Image/Build/Profile/TLWA901NDV1,$(1))
$(call Image/Build/Profile/TLWR741NDV1,$(1))
$(call Image/Build/Profile/TLWR841NV15,$(1))