aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-10 17:04:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-10 17:04:36 +0000
commit3af0a3f4c6d607fce1714fe59899f5c2f91fe89b (patch)
tree74757b1c82af4e21f3b6530e555ba286baac74f0 /target
parent9695b598fb233119fc788a6536747207979c081a (diff)
downloadmaster-187ad058-3af0a3f4c6d607fce1714fe59899f5c2f91fe89b.tar.gz
master-187ad058-3af0a3f4c6d607fce1714fe59899f5c2f91fe89b.tar.bz2
master-187ad058-3af0a3f4c6d607fce1714fe59899f5c2f91fe89b.zip
kernel: prevent -f*-sections from leaking into the boot zImage wrapper on arm
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35938 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-3.8/220-gc_sections.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/220-gc_sections.patch b/target/linux/generic/patches-3.8/220-gc_sections.patch
index 89dc863e45..66312952d6 100644
--- a/target/linux/generic/patches-3.8/220-gc_sections.patch
+++ b/target/linux/generic/patches-3.8/220-gc_sections.patch
@@ -471,3 +471,13 @@
__pv_table_end = .;
}
.init.data : {
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -119,6 +119,7 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
+ ORIG_CFLAGS := $(KBUILD_CFLAGS)
+ KBUILD_CFLAGS = $(subst -pg, , $(ORIG_CFLAGS))
+ endif
++KBUILD_CFLAGS_KERNEL := $(patsubst -f%-sections,,$(KBUILD_CFLAGS_KERNEL))
+
+ ccflags-y := -fpic -fno-builtin -I$(obj)
+ asflags-y := -Wa,-march=all -DZIMAGE