aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-07-15 20:06:53 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-07-15 20:06:53 +0000
commit37d93c17759f35adf0961900b3b2004efc51d565 (patch)
tree1a6addc199e61553553ee64481a7d04e6a53de14 /target
parent26a9aa80de5a938c4d407dc9fb5964f112b0cb13 (diff)
downloadmaster-187ad058-37d93c17759f35adf0961900b3b2004efc51d565.tar.gz
master-187ad058-37d93c17759f35adf0961900b3b2004efc51d565.tar.bz2
master-187ad058-37d93c17759f35adf0961900b3b2004efc51d565.zip
add missing bluetooth kernel stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1452 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/Config.in6
-rw-r--r--target/linux/control/kmod-bluetooth.control6
-rw-r--r--target/linux/linux-2.4/Makefile4
-rw-r--r--target/linux/linux-2.4/config/brcm113
4 files changed, 41 insertions, 88 deletions
diff --git a/target/linux/Config.in b/target/linux/Config.in
index d6a56ee583..bd1faff02e 100644
--- a/target/linux/Config.in
+++ b/target/linux/Config.in
@@ -84,6 +84,12 @@ config BR2_PACKAGE_KMOD_ARPT
help
Kernel modules for ARP firewalling
+config BR2_PACKAGE_KMOD_BLUETOOTH
+ tristate "Bluetooth drivers and network stack"
+ default m
+ help
+ Bluetooth drivers and network stack
+
config BR2_PACKAGE_KMOD_EBT
tristate "Ethernet Bridge firewalling support"
default m
diff --git a/target/linux/control/kmod-bluetooth.control b/target/linux/control/kmod-bluetooth.control
new file mode 100644
index 0000000000..a9bd41ac3b
--- /dev/null
+++ b/target/linux/control/kmod-bluetooth.control
@@ -0,0 +1,6 @@
+Package: kmod-bluetooth
+Priority: optional
+Section: sys
+Maintainer: Markus Becker <mab@comnets.uni-bremen.de>
+Source: http://bluez.org
+Description: Bluetooth support
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index bd25da73e4..6247203d9d 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -69,6 +69,10 @@ $(eval $(call KMOD_template,USB_ACM,usb-acm,\
$(eval $(call KMOD_template,B44,b44,\
$(MODULES_DIR)/kernel/drivers/net/b44.o \
,CONFIG_B44))
+$(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
+ $(MODULES_DIR)/kernel/net/bluetooth/*.o \
+ $(MODULES_DIR)/kernel/drivers/bluetooth/*.o \
+,CONFIG_BLUEZ))
$(eval $(call KMOD_template,ARPT,arptables,\
$(MODULES_DIR)/kernel/net/ipv4/netfilter/arp*.o \
,CONFIG_IP_NF_ARPTABLES))
diff --git a/target/linux/linux-2.4/config/brcm b/target/linux/linux-2.4/config/brcm
index 0202967bd0..648ca2ad6b 100644
--- a/target/linux/linux-2.4/config/brcm
+++ b/target/linux/linux-2.4/config/brcm
@@ -1,5 +1,5 @@
#
-# Automatically generated make config: don't edit
+# Automatically generated by make menuconfig: don't edit
#
CONFIG_MIPS=y
CONFIG_MIPS32=y
@@ -182,10 +182,6 @@ CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_CONCAT is not set
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_CMDLINE_PARTS is not set
-
-#
-# User Modules And Translation Layers
-#
CONFIG_MTD_CHAR=y
CONFIG_MTD_BLOCK=y
# CONFIG_FTL is not set
@@ -250,10 +246,6 @@ CONFIG_MTD_BCM947XX=y
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_MTDRAM is not set
# CONFIG_MTD_BLKMTD is not set
-
-#
-# Disk-On-Chip Device Drivers
-#
# CONFIG_MTD_DOC1000 is not set
# CONFIG_MTD_DOC2000 is not set
# CONFIG_MTD_DOC2001 is not set
@@ -378,7 +370,6 @@ CONFIG_IP_NF_MATCH_OWNER=m
CONFIG_IP_NF_MATCH_LAYER7=m
# CONFIG_IP_NF_MATCH_LAYER7_DEBUG is not set
CONFIG_IP_NF_MATCH_LAYER7_MAXDATALEN=2048
-# CONFIG_IP_NF_MATCH_PHYSDEV is not set
CONFIG_IP_NF_FILTER=y
CONFIG_IP_NF_TARGET_REJECT=y
CONFIG_IP_NF_TARGET_MIRROR=m
@@ -443,10 +434,6 @@ CONFIG_IP6_NF_TARGET_MARK=m
# CONFIG_IP_SCTP is not set
# CONFIG_ATM is not set
CONFIG_VLAN_8021Q=y
-
-#
-#
-#
# CONFIG_IPX is not set
# CONFIG_ATALK is not set
# CONFIG_DECNET is not set
@@ -511,10 +498,6 @@ CONFIG_IDE=m
# IDE, ATA and ATAPI Block devices
#
CONFIG_BLK_DEV_IDE=m
-
-#
-# Please see Documentation/ide.txt for help/info on IDE drives
-#
# CONFIG_BLK_DEV_HD_IDE is not set
# CONFIG_BLK_DEV_HD is not set
# CONFIG_BLK_DEV_IDE_SATA is not set
@@ -528,10 +511,6 @@ CONFIG_IDEDISK_STROKE=y
# CONFIG_BLK_DEV_IDEFLOPPY is not set
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_IDE_TASK_IOCTL is not set
-
-#
-# IDE chipset support/bugfixes
-#
# CONFIG_BLK_DEV_CMD640 is not set
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
# CONFIG_BLK_DEV_ISAPNP is not set
@@ -589,20 +568,12 @@ CONFIG_BLK_DEV_PDC202XX=y
# SCSI support
#
CONFIG_SCSI=m
-
-#
-# SCSI support type (disk, tape, CD-ROM)
-#
CONFIG_BLK_DEV_SD=m
CONFIG_SD_EXTRA_DEVS=5
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
# CONFIG_BLK_DEV_SR is not set
CONFIG_CHR_DEV_SG=m
-
-#
-# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
-#
# CONFIG_SCSI_DEBUG_QUEUES is not set
# CONFIG_SCSI_MULTI_LUN is not set
# CONFIG_SCSI_CONSTANTS is not set
@@ -813,10 +784,6 @@ CONFIG_WL=m
# CONFIG_PLX_HERMES is not set
# CONFIG_TMD_HERMES is not set
# CONFIG_PCI_HERMES is not set
-
-#
-# Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
-#
# CONFIG_PRISM54 is not set
CONFIG_NET_WIRELESS=y
@@ -888,14 +855,6 @@ CONFIG_PRINTER=m
# Joysticks
#
# CONFIG_INPUT_GAMEPORT is not set
-
-#
-# Input core support is needed for gameports
-#
-
-#
-# Input core support is needed for joysticks
-#
# CONFIG_QIC02_TAPE is not set
# CONFIG_IPMI_HANDLER is not set
# CONFIG_IPMI_PANIC_EVENT is not set
@@ -1125,27 +1084,14 @@ CONFIG_NLS_DEFAULT="iso8859-1"
#
CONFIG_USB=m
# CONFIG_USB_DEBUG is not set
-
-#
-# Miscellaneous USB options
-#
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_BANDWIDTH is not set
-
-#
-# USB Host Controller Drivers
-#
CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_UHCI is not set
CONFIG_USB_UHCI_ALT=m
CONFIG_USB_OHCI=m
-
-#
-# USB Device Class drivers
-#
# CONFIG_USB_AUDIO is not set
# CONFIG_USB_EMI26 is not set
-# CONFIG_USB_BLUETOOTH is not set
# CONFIG_USB_MIDI is not set
CONFIG_USB_STORAGE=m
# CONFIG_USB_STORAGE_DEBUG is not set
@@ -1159,15 +1105,7 @@ CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y
CONFIG_USB_ACM=m
CONFIG_USB_PRINTER=m
-
-#
-# USB Human Interface Devices (HID)
-#
# CONFIG_USB_HID is not set
-
-#
-# Input core support is needed for USB HID input layer or HIDBP support
-#
# CONFIG_USB_HIDINPUT is not set
# CONFIG_USB_HIDDEV is not set
# CONFIG_USB_KBD is not set
@@ -1176,47 +1114,23 @@ CONFIG_USB_PRINTER=m
# CONFIG_USB_WACOM is not set
# CONFIG_USB_KBTAB is not set
# CONFIG_USB_POWERMATE is not set
-
-#
-# USB Imaging devices
-#
# CONFIG_USB_DC2XX is not set
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_SCANNER is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USB_HPUSBSCSI is not set
-
-#
-# USB Multimedia devices
-#
-
-#
-# Video4Linux support is needed for USB Multimedia device support
-#
-
-#
-# USB Network adaptors
-#
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_CATC is not set
# CONFIG_USB_CDCETHER is not set
# CONFIG_USB_USBNET is not set
-
-#
-# USB port drivers
-#
# CONFIG_USB_USS720 is not set
#
# USB Serial Converter support
#
# CONFIG_USB_SERIAL is not set
-
-#
-# USB Miscellaneous drivers
-#
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_AUERSWALD is not set
# CONFIG_USB_TIGL is not set
@@ -1231,7 +1145,30 @@ CONFIG_USB_PRINTER=m
#
# Bluetooth support
#
-# CONFIG_BLUEZ is not set
+CONFIG_BLUEZ=m
+CONFIG_BLUEZ_L2CAP=m
+CONFIG_BLUEZ_SCO=m
+CONFIG_BLUEZ_RFCOMM=m
+CONFIG_BLUEZ_RFCOMM_TTY=y
+CONFIG_BLUEZ_BNEP=m
+CONFIG_BLUEZ_BNEP_MC_FILTER=y
+CONFIG_BLUEZ_BNEP_PROTO_FILTER=y
+
+#
+# Bluetooth device drivers
+#
+CONFIG_BLUEZ_HCIUSB=m
+CONFIG_BLUEZ_HCIUSB_SCO=y
+CONFIG_BLUEZ_HCIUART=m
+CONFIG_BLUEZ_HCIUART_H4=y
+CONFIG_BLUEZ_HCIUART_BCSP=y
+CONFIG_BLUEZ_HCIUART_BCSP_TXCRC=y
+# CONFIG_BLUEZ_HCIBFUSB is not set
+# CONFIG_BLUEZ_HCIDTL1 is not set
+# CONFIG_BLUEZ_HCIBT3C is not set
+# CONFIG_BLUEZ_HCIBLUECARD is not set
+# CONFIG_BLUEZ_HCIBTUART is not set
+# CONFIG_BLUEZ_HCIVHCI is not set
#
# Kernel hacking