aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-09-06 13:54:17 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-09-06 13:54:17 +0000
commit31de48c7d8189c97510a51304b0a3f053682a35b (patch)
treea158dbfb66db345f2bf73c27abca592d52d24a75 /target
parent8aff4aace7754393c93b05a0d32fd51fe96ed2a1 (diff)
downloadmaster-187ad058-31de48c7d8189c97510a51304b0a3f053682a35b.tar.gz
master-187ad058-31de48c7d8189c97510a51304b0a3f053682a35b.tar.bz2
master-187ad058-31de48c7d8189c97510a51304b0a3f053682a35b.zip
[brcm63xx] add infrastructure to register gpio-input reset button
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c16
-rw-r--r--target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h3
-rw-r--r--target/linux/brcm63xx/profiles/200-GW6X00.mk2
3 files changed, 20 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
index 2c56a3cf78..0a8ecbd36a 100644
--- a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -802,6 +802,17 @@ static struct platform_device bcm63xx_gpio_leds = {
.dev.platform_data = &bcm63xx_led_data,
};
+struct gpio_buttons_platform_data bcm63xx_gpio_buttons_data = {
+ .poll_interval = 20,
+};
+
+struct platform_device bcm63xx_gpio_buttons_device = {
+ .name = "gpio-buttons",
+ .id = 0,
+ .dev.platform_data = &bcm63xx_gpio_buttons_data,
+};
+
+
/*
* third stage init callback, register all board devices.
*/
@@ -869,6 +880,11 @@ int __init board_register_devices(void)
platform_device_register(&bcm63xx_gpio_leds);
+ bcm63xx_gpio_buttons_data.nbuttons = 1,
+ bcm63xx_gpio_buttons_data.buttons = board.reset_btm;
+
+ platform_device_register(&bcm63xx_gpio_buttons);
+
return 0;
}
diff --git a/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h b/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h
index d154b2859e..e07a07c88c 100644
--- a/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h
+++ b/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h
@@ -56,6 +56,9 @@ struct board_info {
/* GPIO LEDs */
struct gpio_led leds[5];
+
+ /* Reset button */
+ unsigned int reset_btn;
};
#endif /* ! BOARD_BCM963XX_H_ */
diff --git a/target/linux/brcm63xx/profiles/200-GW6X00.mk b/target/linux/brcm63xx/profiles/200-GW6X00.mk
index e2e8c01191..8b7695fa58 100644
--- a/target/linux/brcm63xx/profiles/200-GW6X00.mk
+++ b/target/linux/brcm63xx/profiles/200-GW6X00.mk
@@ -10,7 +10,7 @@ define Profile/GW6X00
PACKAGES:=kmod-b43 kmod-usb-core kmod-usb-ohci kmod-usb-storage \
kmod-fs-ext2 kmod-nls-cp437 kmod-nls-iso8859-1 kmod-fs-vfat \
kmod-loop e2fsprogs kmod-spi-bitbang kmod-bcm63xx-spi \
- kmod-ipt-nathelper-extra \
+ kmod-ipt-nathelper-extra kmod-input-gpio-buttons \
wpa-supplicant iw
endef