aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-03-19 19:38:12 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-03-19 19:38:12 +0000
commit28cfc16e9fbd098ebe822df7f266cf86b1065953 (patch)
tree390c5d19a75000e33986c8593ccef8550ff6e52f /target
parent9c4f0522a87591bd4930e7d5efcb5b9eb884712b (diff)
downloadmaster-187ad058-28cfc16e9fbd098ebe822df7f266cf86b1065953.tar.gz
master-187ad058-28cfc16e9fbd098ebe822df7f266cf86b1065953.tar.bz2
master-187ad058-28cfc16e9fbd098ebe822df7f266cf86b1065953.zip
Fix the uart patch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6615 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120-2.6/patches/004-adm5120_uart.patch35
1 files changed, 21 insertions, 14 deletions
diff --git a/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch b/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
index c0bb0d37d7..6f2ef7bb36 100644
--- a/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
+++ b/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
@@ -1,22 +1,29 @@
+diff -urN linux-2.6.19.2/drivers/serial/Kconfig linux-2.6.19.2-adm5120/drivers/serial/Kconfig
+--- linux-2.6.19.2/drivers/serial/Kconfig 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2-adm5120/drivers/serial/Kconfig 2007-01-23 01:13:39.000000000 +0100
+@@ -246,6 +246,22 @@
+
+ comment "Non-8250 serial port support"
+
+config SERIAL_ADM5120
-+ bool "ADM5120 serial port support"
-+ depends on MIPS_ADM5120
-+ select SERIAL_CORE
-+ select SERIAL_CORE_CONSOLE
-+ help
-+ Driver for the on chip UARTs on the ADM5120 SoC
++ bool "ADM5120 serial port support"
++ depends on MIPS_ADM5120
++ select SERIAL_CORE
++ select SERIAL_CORE_CONSOLE
++ help
++ Driver for the on chip UARTs on the ADM5120 SoC
+
+config ADM5120_NR_UARTS
-+ int "Maximum number of ADM5120 serial ports"
-+ depends on SERIAL_ADM5120
-+ default "2"
-+ ---help---
-+ Set this to the number of serial ports you want the driver to
-+ support.
++ int "Maximum number of ADM5120 serial ports"
++ depends on SERIAL_ADM5120
++ default "2"
++ ---help---
++ Set this to the number of serial ports you want the driver to
++ support.
+
config SERIAL_AMBA_PL010
- tristate "ARM AMBA PL010 serial port support"
- depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)
+ tristate "ARM AMBA PL010 serial port support"
+ depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)
diff -urN linux-2.6.19.2/drivers/serial/Makefile linux-2.6.19.2-adm5120/drivers/serial/Makefile
--- linux-2.6.19.2/drivers/serial/Makefile 2007-01-10 20:10:37.000000000 +0100
+++ linux-2.6.19.2-adm5120/drivers/serial/Makefile 2007-01-23 01:21:45.000000000 +0100