aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-25 11:28:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-25 11:28:40 +0000
commit11c3087be1b791b933fbc031cdd0811a53cbd3e0 (patch)
tree152e22e247dcb0e5d9f5f20a3ff482fa31b91941 /target
parent4b5411bdc98e997021c5d48ec6a4c76230058afd (diff)
downloadmaster-187ad058-11c3087be1b791b933fbc031cdd0811a53cbd3e0.tar.gz
master-187ad058-11c3087be1b791b933fbc031cdd0811a53cbd3e0.tar.bz2
master-187ad058-11c3087be1b791b933fbc031cdd0811a53cbd3e0.zip
add cpmac ipv6 patch from mache
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1747 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/linux-2.4/patches/ar7/003-net_driver_cpmac.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/linux-2.4/patches/ar7/003-net_driver_cpmac.patch b/target/linux/linux-2.4/patches/ar7/003-net_driver_cpmac.patch
index 68d7f3f7e7..11329910e0 100644
--- a/target/linux/linux-2.4/patches/ar7/003-net_driver_cpmac.patch
+++ b/target/linux/linux-2.4/patches/ar7/003-net_driver_cpmac.patch
@@ -13317,3 +13317,25 @@ diff -urN linux.old/drivers/net/Makefile linux.dev/drivers/net/Makefile
# link order important here
#
obj-$(CONFIG_PLIP) += plip.o
+--- linux.old/drivers/net/avalanche_cpmac/cpmac.c 2005-08-25 10:56:33.702931008 +0200
++++ linux.dev/drivers/net/avalanche_cpmac/cpmac.c 2005-08-25 11:08:45.027451520 +0200
+@@ -2158,17 +2158,16 @@
+ CPMAC_PRIVATE_INFO_T *p_cpmac_priv = p_dev->priv;
+ CPMAC_DRV_HAL_INFO_T *p_drv_hal = p_cpmac_priv->drv_hal;
+ struct sk_buff *p_skb = fragList[0].OsInfo;
+- p_skb->len = fragList[0].len;
+
+ /* invalidate the cache. */
+ dma_cache_inv((unsigned long)p_skb->data, fragList[0].len);
+ #ifdef CPMAC_TEST
+- xdump(p_skb->data, p_skb->len, "recv");
++ xdump(p_skb->data, fragList[0].len, "recv");
+ #endif
+ #ifdef CPMAC_8021Q_SUPPORT
+ /* 802.1q stuff, just does the basic checking here. */
+ if(!p_cpmac_priv->enable_802_1q &&
+- p_skb->len > TCI_END_OFFSET &&
++ fragList[0].len > TCI_END_OFFSET &&
+ IS_802_1Q_FRAME(p_skb->data + TPID_START_OFFSET))
+ {
+ goto cpmac_hal_recv_frame_mismatch;