aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-01 00:51:17 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-01 00:51:17 +0000
commit08fddea857c8aa289c7c054efdae7ffe2dccd3ff (patch)
tree937b3d03449335eb94981bb3110615071eed85ff /target
parent16883252cf690554163c1696bcfd26894d1741f9 (diff)
downloadmaster-187ad058-08fddea857c8aa289c7c054efdae7ffe2dccd3ff.tar.gz
master-187ad058-08fddea857c8aa289c7c054efdae7ffe2dccd3ff.tar.bz2
master-187ad058-08fddea857c8aa289c7c054efdae7ffe2dccd3ff.zip
brcm63xx: add DT support for DSL-2650U
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43452 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/dts/dsl-2650u.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch3
-rw-r--r--target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/508-board_hw553.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch2
-rw-r--r--target/linux/brcm63xx/profiles/d-link.mk10
7 files changed, 47 insertions, 6 deletions
diff --git a/target/linux/brcm63xx/dts/dsl-2650u.dts b/target/linux/brcm63xx/dts/dsl-2650u.dts
new file mode 100644
index 0000000000..23b33017cb
--- /dev/null
+++ b/target/linux/brcm63xx/dts/dsl-2650u.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "D-Link DSL-2650U";
+ compatible = "d-link,dsl-2650u", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ linux@10000 {
+ label = "linux";
+ reg = <0x010000 0x7e0000>;
+ };
+
+ nvram@7f0000 {
+ label = "nvram";
+ reg = <0x7f0000 0x010000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 39dfb0a516..939d8e0681 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -208,8 +208,6 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
# D-Link DSL-2640B, rev B2
$(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
- # D-Link DSL-2650U
- $(call Image/Build/CFE,$(1),96358VW2,6358,DSL2650U)
# TP-Link 8900GB
$(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
@@ -288,6 +286,8 @@ $(eval $(call ImageDTB,CFEDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,--pad
$(eval $(call ImageDTB,CFEDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,--pad 4))
# Comtrend WAP-5813n
$(eval $(call ImageDTB,CFEDTB,WAP5813n,wap-5813n,96369R-1231N,6368,WAP-5813n,--pad 4))
+# D-Link DSL-2650U
+$(eval $(call ImageDTB,CFEDTB,DSL2650U,dsl-2650u,96358VW2,6358,DSL2650U))
# D-Link DSL-2740B/DSL-2741B, rev C2
$(eval $(call ImageDTB,CFEDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
# D-Link DSL-2740B/DSL-2741B, rev C3
diff --git a/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch b/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
index a602017d38..a38fca589f 100644
--- a/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
+++ b/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,44 @@ static const struct board_info __initcon
+@@ -736,6 +736,45 @@ static const struct board_info __initcon
};
static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -45,6 +45,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
+ { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
+ { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
++ { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
+ { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
+ { .compatible = "pirelli,a226m", .data = &board_DWVS0, },
+ { .compatible = "pirelli,a226m-fwb", .data = &board_DWVS0, },
diff --git a/target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch b/target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch
index 791db6973d..d1433607e6 100644
--- a/target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch
+++ b/target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch
@@ -75,6 +75,6 @@
{ .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
{ .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
+ { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+ { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
{ .compatible = "pirelli,a226g", .data = &board_DWVS0, },
{ .compatible = "pirelli,a226m", .data = &board_DWVS0, },
- { .compatible = "pirelli,a226m-fwb", .data = &board_DWVS0, },
diff --git a/target/linux/brcm63xx/patches-3.14/508-board_hw553.patch b/target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
index f45371e0f9..e08550d7e0 100644
--- a/target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
+++ b/target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
@@ -93,9 +93,9 @@
};
@@ -1538,6 +1616,7 @@ static struct of_device_id const bcm963x
- { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
{ .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+ { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
+ { .compatible = "huawei,hg553", .data = &board_HW553, },
{ .compatible = "pirelli,a226g", .data = &board_DWVS0, },
{ .compatible = "pirelli,a226m", .data = &board_DWVS0, },
diff --git a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
index 6f60088035..eef548dab7 100644
--- a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
+++ b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
@@ -83,9 +83,9 @@
#ifdef CONFIG_BCM63XX_CPU_6368
@@ -2548,6 +2616,7 @@ static struct of_device_id const bcm963x
- { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
{ .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
{ .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+ { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
+ { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
{ .compatible = "huawei,hg553", .data = &board_HW553, },
{ .compatible = "pirelli,a226g", .data = &board_DWVS0, },
diff --git a/target/linux/brcm63xx/profiles/d-link.mk b/target/linux/brcm63xx/profiles/d-link.mk
index 69c2fc8639..4bfefb9ee4 100644
--- a/target/linux/brcm63xx/profiles/d-link.mk
+++ b/target/linux/brcm63xx/profiles/d-link.mk
@@ -5,6 +5,16 @@
# See /LICENSE for more information.
#
+define Profile/DSL2650U
+ NAME:=D-Link DSL-2650U
+ PACKAGES:=kmod-b43 wpad-mini\
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/DSL2650U/Description
+ Package set optimized for DSL-2650U.
+endef
+$(eval $(call Profile,DSL2650U))
+
define Profile/DSL274XB_C
NAME:=D-Link DSL-2740B/DSL-2741B rev C2/C3
PACKAGES:=kmod-b43 wpad-mini