aboutsummaryrefslogtreecommitdiffstats
path: root/target/utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 23:29:05 +0000
commit56ca36174338f3a0029b39ed7782c0410cf2d2fe (patch)
tree8e70523a0c222f26aa84bf3382deceee6b406752 /target/utils/Makefile
parent5f27fa5f8c930ad9de6c41028ffd4a8bad876e1b (diff)
downloadmaster-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.tar.gz
master-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.tar.bz2
master-187ad058-56ca36174338f3a0029b39ed7782c0410cf2d2fe.zip
cleanup; replace .PHONY with FORCE; disable gdb by default
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3877 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/utils/Makefile')
-rw-r--r--target/utils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/utils/Makefile b/target/utils/Makefile
index 5b0f2470b4..fe354754ce 100644
--- a/target/utils/Makefile
+++ b/target/utils/Makefile
@@ -5,12 +5,12 @@ TARGETS := addpattern trx motorola-bin dgfirmware
UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS))
+compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
mkdir -p $(STAGING_DIR)/bin
$(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
install: compile
package:
-clean:
+clean: FORCE
rm -rf $(UTILS_BUILD_DIR)
for f in $(TARGETS); do \
rm -f $(STAGING_DIR)/bin/$$f ; \