aboutsummaryrefslogtreecommitdiffstats
path: root/target/toolchain
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:37 +0000
commit4a998150c4e708ab67e48e95032db52f3145e7c4 (patch)
tree0cdb220e5bc10a1455597e2958cde4ce4af2dcd3 /target/toolchain
parent6a61b200d89cd362fefbf4a7fa5a3493bb9ba8f1 (diff)
downloadmaster-187ad058-4a998150c4e708ab67e48e95032db52f3145e7c4.tar.gz
master-187ad058-4a998150c4e708ab67e48e95032db52f3145e7c4.tar.bz2
master-187ad058-4a998150c4e708ab67e48e95032db52f3145e7c4.zip
toolchain: respect CONFIG_VERSION_FILENAMES and add host system suffix
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/toolchain')
-rw-r--r--target/toolchain/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/toolchain/Makefile b/target/toolchain/Makefile
index 6e60a08231..67c908530f 100644
--- a/target/toolchain/Makefile
+++ b/target/toolchain/Makefile
@@ -13,10 +13,7 @@ include $(INCLUDE_DIR)/host.mk
override MAKEFLAGS=
-PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-
-TOOLCHAIN_NAME:=OpenWrt-Toolchain-$(BOARD)-for-$(ARCH)$(ARCH_SUFFIX)-gcc-$(GCCV)$(DIR_SUFFIX)
+TOOLCHAIN_NAME:=OpenWrt-Toolchain-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
TOOLCHAIN_BUILD_DIR:=$(BUILD_DIR)/$(TOOLCHAIN_NAME)
EXCLUDE_DIRS:=*/ccache \
*/initial \