aboutsummaryrefslogtreecommitdiffstats
path: root/target/toolchain
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-09-04 11:56:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-09-04 11:56:33 +0000
commit047f0425682a9998f012de50b538b5bcde32717f (patch)
treef74af6877583366ce8b2c89369f2db7ce80f84ef /target/toolchain
parentef67285052e7e7e72c9609ad2721436c3bd26f0f (diff)
downloadmaster-187ad058-047f0425682a9998f012de50b538b5bcde32717f.tar.gz
master-187ad058-047f0425682a9998f012de50b538b5bcde32717f.tar.bz2
master-187ad058-047f0425682a9998f012de50b538b5bcde32717f.zip
target/toolchain: fix installation after r22723
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22887 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/toolchain')
-rw-r--r--target/toolchain/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/toolchain/Makefile b/target/toolchain/Makefile
index 1e0dec2dd1..0db18d1ac1 100644
--- a/target/toolchain/Makefile
+++ b/target/toolchain/Makefile
@@ -38,9 +38,9 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
$(CP) $(TOPDIR)/LICENSE ./files/README.TOOLCHAIN \
$(TOOLCHAIN_BUILD_DIR)/
- $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
- chmod +x $(TOOLCHAIN_PREFIX)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
- (cd $(TOOLCHAIN_PREFIX)/usr/bin; \
+ $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+ chmod +x $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
+ (cd $(TOOLCHAIN_PREFIX)/bin; \
for app in cc gcc g++ c++ cpp ld as ; do \
[ -f $(REAL_GNU_TARGET_NAME)-$${app} ] && mv $(REAL_GNU_TARGET_NAME)-$${app} $(REAL_GNU_TARGET_NAME)-$${app}.bin ; \
ln -sf $(REAL_GNU_TARGET_NAME)-wrapper.sh $(REAL_GNU_TARGET_NAME)-$${app} ; \