aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-09-17 10:25:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-09-17 10:25:47 +0000
commitdfbf70b43d31cf05ff9d06c9cf2f1577f6c86e63 (patch)
tree4138d1ffb14c96aa204e698f12a738ee2a54866d /target/sdk
parent06cbf4e0a3a58726185362d77737af0cb5a582e2 (diff)
downloadmaster-187ad058-dfbf70b43d31cf05ff9d06c9cf2f1577f6c86e63.tar.gz
master-187ad058-dfbf70b43d31cf05ff9d06c9cf2f1577f6c86e63.tar.bz2
master-187ad058-dfbf70b43d31cf05ff9d06c9cf2f1577f6c86e63.zip
sdk: predefine kernel version magic
Kernel modules which are built using the SDK do not have access to the .vermagic file in the Linux build dir, therefore the generated .ipk metadata depends on kernel versions like '3.10.49-1-unknown' which are not satisfiable by the kernel meta package in the image. Fix this problem by substituting 'unknown' with the current version magic in include/kernel.mk when packing the SDK. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42590 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index a2cd3a5ab0..1c696d5ac4 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -108,6 +108,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
cat $(TOPDIR)/feeds.conf.default \
>> $(SDK_BUILD_DIR)/feeds.conf.default
$(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(SDK_BUILD_DIR)/include/version.mk
+ $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(SDK_BUILD_DIR)/include/kernel.mk
find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf