aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-11-07 12:59:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-11-07 12:59:11 +0000
commitf56da26294df97a23811d69b8afc237908f08e52 (patch)
tree40d5287d158a357a6aaf6ade8e1bf8d8afa75955 /target/linux
parent10c12741af38a3070b1bc1ecd61fe8f11dd64aa8 (diff)
downloadmaster-187ad058-f56da26294df97a23811d69b8afc237908f08e52.tar.gz
master-187ad058-f56da26294df97a23811d69b8afc237908f08e52.tar.bz2
master-187ad058-f56da26294df97a23811d69b8afc237908f08e52.zip
ar71xx: build image for the Buffalo WHR-HP-GN
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28806 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/generic/profiles/buffalo.mk12
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/buffalo.mk b/target/linux/ar71xx/generic/profiles/buffalo.mk
index a6de0af2be..74530b5e75 100644
--- a/target/linux/ar71xx/generic/profiles/buffalo.mk
+++ b/target/linux/ar71xx/generic/profiles/buffalo.mk
@@ -49,3 +49,15 @@ define Profile/WHRHPG300N/Description
endef
$(eval $(call Profile,WHRHPG300N))
+
+
+define Profile/WHRHPGN
+ NAME:=Buffalo WHR-HP-GN
+ PACKAGES:=
+endef
+
+define Profile/WHRHPGN/Description
+ Package set optimized for the Buffalo WHR-HP-GN.
+endef
+
+$(eval $(call Profile,WHRHPGN))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c070eac360..a4b851fe34 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -718,6 +718,11 @@ define Image/Build/Profile/WHRHPG300N
$(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-hp-g300n,$(whrhpg300n_cmdline),whrhpg300n_mtdlayout,WHR-HP-G300N)
endef
+whrhpgn_cmdline=board=WHR-HP-GN console=ttyS0,115200
+define Image/Build/Profile/WHRHPGN
+ $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-hp-gn,$(whrhpgn_cmdline),whrhpg300n_mtdlayout,WHR-HP-GN)
+endef
+
wzrhpg300nh_cmdline=board=WZR-HP-G300NH console=ttyS0,115200
define Image/Build/Profile/WZRHPG300NH
$(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,$(wzrhpg300nh_cmdline),WZR-HP-G300NH)
@@ -792,6 +797,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WRT160NL,$(1))
$(call Image/Build/Profile/WHRG301N,$(1))
$(call Image/Build/Profile/WHRHPG300N,$(1))
+ $(call Image/Build/Profile/WHRHPGN,$(1))
$(call Image/Build/Profile/WZRHPG300NH,$(1))
$(call Image/Build/Profile/WZRHPAG300H,$(1))
$(call Image/Build/Profile/ZCN1523H28,$(1))