aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-11 15:55:17 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-11 15:55:17 +0000
commitf0528344418d3db0819d23a65782bbceab011182 (patch)
tree5034c27779f7185df2100886902e3ffd87b3516e /target/linux
parentdadf739365bc058b30b4d1f15ecd8ff7853a13d3 (diff)
downloadmaster-187ad058-f0528344418d3db0819d23a65782bbceab011182.tar.gz
master-187ad058-f0528344418d3db0819d23a65782bbceab011182.tar.bz2
master-187ad058-f0528344418d3db0819d23a65782bbceab011182.zip
ar71xx: add profile support for dir-835-a1
Signed-off-by: Alexander Stadler <sa.maillists@univie.ac.at> Patchwork: http://patchwork.openwrt.org/patch/3427/mbox/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35959 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
index b668ed26dd..f30e9b1ecb 100644
--- a/target/linux/ar71xx/generic/profiles/d-link.mk
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -72,3 +72,14 @@ define Profile/DIR825C1/Description
endef
$(eval $(call Profile,DIR825C1))
+
+define Profile/DIR835A1
+ NAME:=D-Link DIR-835 rev. A1
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR835A1/Description
+ Package set optimized for the D-Link DIR-835 rev. A1.
+endef
+
+$(eval $(call Profile,DIR835A1))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 20caff83f5..8a15af9c8c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -859,6 +859,7 @@ $(eval $(call SingleProfile,Cameo913x,$(fs_squash),TEW652BRP_RECOVERY,tew-652brp
$(eval $(call SingleProfile,Cameo933x,$(fs_squash),TEW712BR,tew-712br,TEW-712BR,ttyATH0,115200,"HORNET-RT-TEW712BR-3"))
$(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR825C1,dir-825-c1,DIR-825-C1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
+$(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR835A1,dir-835-a1,DIR-835-A1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
$(eval $(call SingleProfile,CyberTAN,$(fs_64k),WRT160NL,wrt160nl,WRT160NL,ttyS0,115200,1.00.01))