aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-23 12:27:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-23 12:27:28 +0000
commitce15b12727afadbfaa5d416f6398d6f24b72294d (patch)
treec7cfc54769d304df60afa829776cfa0228e6e2aa /target/linux
parent1a9d146ed5a14ffa2d6efb6948389f3512753f74 (diff)
downloadmaster-187ad058-ce15b12727afadbfaa5d416f6398d6f24b72294d.tar.gz
master-187ad058-ce15b12727afadbfaa5d416f6398d6f24b72294d.tar.bz2
master-187ad058-ce15b12727afadbfaa5d416f6398d6f24b72294d.zip
ar71xx: image: show size limit in warning messages
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39376 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e9ffd77d9c..64cd854a30 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -142,9 +142,9 @@ define CatFiles
rm -f $(5); \
fi; \
else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
- echo "Warning: $(1) is too big" >&2; \
+ echo "Warning: $(1) is too big (> $(2) bytes)" >&2; \
else if [ `stat -c%s $(3)` -gt $(4) ]; then \
- echo "Warning: $(3) is too big" >&2; \
+ echo "Warning: $(3) is too big (> $(4) bytes)" >&2; \
else \
( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
fi; fi; fi