aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-01-12 19:04:54 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-01-12 19:04:54 +0000
commitade4aa1014ce28e9a525d840deb2d2a1c4f06519 (patch)
tree0db2a1802bd3a8b0abe09b9aa7db56562f05ee0a /target/linux
parentd88816540f01c34c83e83b1c5ddd8728fee910a1 (diff)
downloadmaster-187ad058-ade4aa1014ce28e9a525d840deb2d2a1c4f06519.tar.gz
master-187ad058-ade4aa1014ce28e9a525d840deb2d2a1c4f06519.tar.bz2
master-187ad058-ade4aa1014ce28e9a525d840deb2d2a1c4f06519.zip
brcm47xx: add brcmsmac + bgmac profile
Signed-off-by: Cody P Schafer <devel@codyps.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39258 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk b/target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk
new file mode 100644
index 0000000000..d9dc9e7a4a
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-brcmsmac
+ NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (brcmsmac)
+ PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-bgmac-brcmsmac/Description
+ Package set compatable with newer gigabit + N based bcm47xx SoCs with
+ Broadcom BCM43xx Wifi cards using the mac80211 brcmsmac driver and
+ bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-brcmsmac))
+