aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-06 14:48:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-06 14:48:56 +0000
commitab8a53dfaecb891d8f5ebc9e77eb940ffd4fa66a (patch)
tree3b01bf8268e23d2abe013c1232a05b802d14b090 /target/linux
parent39bc82472df14c3ade0ee7724bb48f1f2ea787f3 (diff)
downloadmaster-187ad058-ab8a53dfaecb891d8f5ebc9e77eb940ffd4fa66a.tar.gz
master-187ad058-ab8a53dfaecb891d8f5ebc9e77eb940ffd4fa66a.tar.bz2
master-187ad058-ab8a53dfaecb891d8f5ebc9e77eb940ffd4fa66a.zip
imx23: fix kernel module dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37181 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/imx23/modules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/imx23/modules.mk b/target/linux/imx23/modules.mk
index 1e27e415ac..fb81cef91c 100644
--- a/target/linux/imx23/modules.mk
+++ b/target/linux/imx23/modules.mk
@@ -7,7 +7,7 @@
define KernelPackage/rtc-stmp3xxx
SUBMENU:=$(OTHER_MENU)
TITLE:=STMP3xxx SoC built-in RTC support
- DEPENDS:=@(TARGET_imx23)
+ DEPENDS:=@TARGET_imx23
$(call AddDepends/rtc)
KCONFIG:=\
CONFIG_RTC_CLASS=y \
@@ -35,6 +35,7 @@ $(eval $(call KernelPackage,wdt-stmp3xxx))
define KernelPackage/usb-chipidea
TITLE:=Support for ChipIdea controllers
+ DEPENDS:=@TARGET_imx23
KCONFIG:= \
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
@@ -70,6 +71,7 @@ $(eval $(call KernelPackage,usb-mxs-phy,1))
define KernelPackage/usb-net-smsc95xx
TITLE:=SMSC95xx USB/2.0 Ethernet driver
+ DEPENDS:=@TARGET_imx23
KCONFIG:=CONFIG_USB_NET_SMSC95XX
FILES:=$(LINUX_DIR)/drivers/net/usb/smsc95xx.ko
AUTOLOAD:=$(call AutoLoad,64,smsc95xx)