aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-09-03 01:03:22 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-09-03 01:03:22 +0000
commit9f151e244d535da52cf38e5a8a2cdc508476b321 (patch)
tree9ecee5b9edf292c0c666b489366b94c7f1c34823 /target/linux
parentf9ae3166568a410eb99e67eb0a5f1119766bebae (diff)
downloadmaster-187ad058-9f151e244d535da52cf38e5a8a2cdc508476b321.tar.gz
master-187ad058-9f151e244d535da52cf38e5a8a2cdc508476b321.tar.bz2
master-187ad058-9f151e244d535da52cf38e5a8a2cdc508476b321.zip
[kirkwood] Add kernel package for the mv_cesa crypto module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22877 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/kirkwood/modules.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644
index 0000000000..ed7fe883a5
--- /dev/null
+++ b/target/linux/kirkwood/modules.mk
@@ -0,0 +1,11 @@
+
+define KernelPackage/crypto-mv_cesa
+ TITLE:=Marvell crypto engine
+ KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+ FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+ AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+ SUBMENU:=Cryptographic API modules
+ DEPENDS:=kmod-crypto-core
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))