aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-03-10 22:45:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-03-10 22:45:10 +0000
commit946ddacf51495489774cec792840e87be2deac86 (patch)
tree008457bde5c3b3ebeb4b97a39cc76d531d77f4d0 /target/linux
parent9bce66cc571f5026496a710df6552686aec56d65 (diff)
downloadmaster-187ad058-946ddacf51495489774cec792840e87be2deac86.tar.gz
master-187ad058-946ddacf51495489774cec792840e87be2deac86.tar.bz2
master-187ad058-946ddacf51495489774cec792840e87be2deac86.zip
fix apex compile on osx, suppress some build warnings
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10582 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ixp4xx/image/apex/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/image/apex/Makefile b/target/linux/ixp4xx/image/apex/Makefile
index 789d4f2131..10621e766d 100644
--- a/target/linux/ixp4xx/image/apex/Makefile
+++ b/target/linux/ixp4xx/image/apex/Makefile
@@ -19,6 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
PKG_MD5SUM:=5feb7a05431e5e8a4aa36fb23347de8e
include $(INCLUDE_DIR)/package.mk
+export GCC_HONOUR_COPTS=s
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
@@ -30,6 +31,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ KBUILD_HAVE_NLS=no \
ARCH=arm \
all
endef