aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-04-01 12:05:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-04-01 12:05:27 +0000
commit508ed126fce54e34107dc4335fe1639d5f57a098 (patch)
treea5cda6cdb0bffcdceb04c0066c69647b1bee39a8 /target/linux
parent25005baa1279d34b9c485f553f71076651f107e8 (diff)
downloadmaster-187ad058-508ed126fce54e34107dc4335fe1639d5f57a098.tar.gz
master-187ad058-508ed126fce54e34107dc4335fe1639d5f57a098.tar.bz2
master-187ad058-508ed126fce54e34107dc4335fe1639d5f57a098.zip
[x86]: add a subtarget and drivers for the Intel Tolapai SoC
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic-2.6/config-2.6.321
-rw-r--r--target/linux/x86/Makefile2
-rw-r--r--target/linux/x86/ep80579/config-default12
-rw-r--r--target/linux/x86/ep80579/target.mk9
4 files changed, 23 insertions, 1 deletions
diff --git a/target/linux/generic-2.6/config-2.6.32 b/target/linux/generic-2.6/config-2.6.32
index a9c4bfb824..b869c9ae97 100644
--- a/target/linux/generic-2.6/config-2.6.32
+++ b/target/linux/generic-2.6/config-2.6.32
@@ -550,6 +550,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index cd7c1b5c01..4cf011af78 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
-SUBTARGETS=generic olpc xen_domu
+SUBTARGETS=generic olpc xen_domu ep80579
LINUX_VERSION:=2.6.32.10
diff --git a/target/linux/x86/ep80579/config-default b/target/linux/x86/ep80579/config-default
new file mode 100644
index 0000000000..2a89b4fe6f
--- /dev/null
+++ b/target/linux/x86/ep80579/config-default
@@ -0,0 +1,12 @@
+CONFIG_ATA=y
+CONFIG_BLK_DEV_SD=y
+# CONFIG_MTD_BLOCK2MTD is not set
+CONFIG_HIGHMEM4G=y
+# CONFIG_HIGHPTE is not set
+# CONFIG_MTD is not set
+# CONFIG_NOHIGHMEM is not set
+CONFIG_SATA_AHCI=y
+# CONFIG_SQUASHFS is not set
+CONFIG_ITCO_WDT=y
+# CONFIG_ITCO_VENDOR_SUPPORT is not set
+CONFIG_LOG_BUF_SHIFT=17
diff --git a/target/linux/x86/ep80579/target.mk b/target/linux/x86/ep80579/target.mk
new file mode 100644
index 0000000000..00fe1abc3d
--- /dev/null
+++ b/target/linux/x86/ep80579/target.mk
@@ -0,0 +1,9 @@
+BOARDNAME:=Intel EP80579
+DEFAULT_PACKAGES += kmod-ep80579-can kmod-ep80579-eth kmod-ep80579-misc \
+ kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci
+
+define Target/Description
+ Build firmware images for Intel EP80579 based boards
+ (e.g : ADI Engineering Ocracoke Island)
+endef
+