aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-26 15:29:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-26 15:29:53 +0000
commit338c3d3cbc241817e7870ebbc4cb7ba6a16f7564 (patch)
treed95da099b7111a598b135c8473f21368c1a263ca /target/linux
parentb978cbd458137029deb0781a3bc646bec31466bc (diff)
downloadmaster-187ad058-338c3d3cbc241817e7870ebbc4cb7ba6a16f7564.tar.gz
master-187ad058-338c3d3cbc241817e7870ebbc4cb7ba6a16f7564.tar.bz2
master-187ad058-338c3d3cbc241817e7870ebbc4cb7ba6a16f7564.zip
Revert "kernel: remove all local symbols from kernel modules at link time to reduce their size"
Use -x when stripping kernel modules instead git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26305 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch11
-rw-r--r--target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch2
-rw-r--r--target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch11
-rw-r--r--target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch2
4 files changed, 2 insertions, 24 deletions
diff --git a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
deleted file mode 100644
index 2e2508125d..0000000000
--- a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -360,7 +360,7 @@
- KBUILD_AFLAGS := -D__ASSEMBLY__
- KBUILD_AFLAGS_MODULE := -DMODULE
- KBUILD_CFLAGS_MODULE := -DMODULE
--KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
-+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
-
- # Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
index 47f796a909..861a6b7538 100644
--- a/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-2.6.37/950-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
@@ -361,6 +361,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+KBUILD_LDFLAGS_MODULE_PREREQ :=
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
diff --git a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
deleted file mode 100644
index 86a3e2f1f8..0000000000
--- a/target/linux/generic/patches-2.6.38/015-strip_module_local_symbols.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -361,7 +361,7 @@
- KBUILD_AFLAGS := -D__ASSEMBLY__
- KBUILD_AFLAGS_MODULE := -DMODULE
- KBUILD_CFLAGS_MODULE := -DMODULE
--KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
-+KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
-
- # Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
diff --git a/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch b/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
index 2d3a67d12b..402cd0cacb 100644
--- a/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
+++ b/target/linux/generic/patches-2.6.38/950-powerpc_crtsavres_prereq.patch
@@ -3,7 +3,7 @@
@@ -362,6 +362,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
- KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+ KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
+KBUILD_LDFLAGS_MODULE_PREREQ :=
# Read KERNELRELEASE from include/config/kernel.release (if it exists)