aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-02 19:05:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-02 19:05:56 +0000
commit13806122f65e4f5431bacaa70381da08881aa2bb (patch)
tree7ff10ab669780393b9a9d87c1841eef095a38977 /target/linux
parent129b5090a37610254721ae4fdbf47a41083785ec (diff)
downloadmaster-187ad058-13806122f65e4f5431bacaa70381da08881aa2bb.tar.gz
master-187ad058-13806122f65e4f5431bacaa70381da08881aa2bb.tar.bz2
master-187ad058-13806122f65e4f5431bacaa70381da08881aa2bb.zip
ar71xx: image: simplify oneliner loader macros
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37887 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e6149afa37..f99655edd7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -514,9 +514,7 @@ define Image/Build/UBNT
$(call sysupname,$(1),$(2))
endef
-define Image/Build/Planex/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
-endef
+Image/Build/Planex/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
define Image/Build/Planex
[ -e "$(KDIR)/loader-$(2).gz" ]
@@ -556,9 +554,7 @@ endef
Image/Build/ALFA/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
-define Image/Build/TPLINKOLD/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-endef
+Image/Build/TPLINKOLD/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
define Image/Build/TPLINKOLD
[ -e "$(KDIR)/loader-$(2).gz" ]
@@ -587,9 +583,7 @@ define Image/Build/TPLINKOLD/initramfs
-o $(call imgname,$(1),$(2))-initramfs-uImage.bin
endef
-define Image/Build/TPLINK/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-endef
+Image/Build/TPLINK/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
define Image/Build/TPLINK
[ -e "$(KDIR)/loader-$(2).gz" ]