aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-04-10 21:34:21 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-04-10 21:34:21 +0000
commit033fddd734c439679d7c1160c070a93f2e274bd0 (patch)
treecec566d9938bd5cbd887702e4de8170e4e6c70d1 /target/linux
parente7eaef8bc0da33f88099bcd197d7a52ea724734a (diff)
downloadmaster-187ad058-033fddd734c439679d7c1160c070a93f2e274bd0.tar.gz
master-187ad058-033fddd734c439679d7c1160c070a93f2e274bd0.tar.bz2
master-187ad058-033fddd734c439679d7c1160c070a93f2e274bd0.zip
mxs: Include the right kernel image in the rootfs
Signed-off-by: Harald Geyer <harald@ccbib.org> Acked-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45368 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/mxs/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 55e88c25f3..9830a7d616 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -22,10 +22,15 @@ endef
define Image/InstallKernel
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
mkdir -p $(TARGET_DIR)/boot
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(TARGET_DIR)/boot/
endif
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ mkdir -p $(TARGET_DIR)/boot
+ cp $(KDIR)/uImage $(TARGET_DIR)/boot/
+ endif
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
mkdir -p $(TARGET_DIR)/boot