aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/zynq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-26 11:44:29 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-26 11:44:29 +0000
commitc7742558dc6c4420b08a8f12c28ddffa51c92f2d (patch)
tree003b3e1a1d9536f93dbc7d31fda65764f7e3ac1c /target/linux/zynq
parent24ef2c55861b889503decd6a45d281c0184d0eea (diff)
downloadmaster-187ad058-c7742558dc6c4420b08a8f12c28ddffa51c92f2d.tar.gz
master-187ad058-c7742558dc6c4420b08a8f12c28ddffa51c92f2d.tar.bz2
master-187ad058-c7742558dc6c4420b08a8f12c28ddffa51c92f2d.zip
zynq: Add Zybo device support
Signed-off-by: Jason Wu <jason.wu.misc@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49257 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/zynq')
-rwxr-xr-xtarget/linux/zynq/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/zynq/image/Makefile4
-rw-r--r--target/linux/zynq/profiles/zybo.mk16
3 files changed, 21 insertions, 1 deletions
diff --git a/target/linux/zynq/base-files/etc/board.d/02_network b/target/linux/zynq/base-files/etc/board.d/02_network
index 35667c0610..9659673618 100755
--- a/target/linux/zynq/base-files/etc/board.d/02_network
+++ b/target/linux/zynq/base-files/etc/board.d/02_network
@@ -6,7 +6,7 @@
board_config_update
case "$(cat /tmp/sysinfo/board_name)" in
- xlnx,zynq-zc702|xlnx,zynq-zed)
+ xlnx,zynq-zc702|xlnx,zynq-zed|xlnx,zynq-zybo)
ucidef_set_interface_lan 'eth0'
;;
esac
diff --git a/target/linux/zynq/image/Makefile b/target/linux/zynq/image/Makefile
index 87975be6a0..d803c336b8 100644
--- a/target/linux/zynq/image/Makefile
+++ b/target/linux/zynq/image/Makefile
@@ -74,6 +74,10 @@ define Device/ZED
$(call Device/DefaultConfig,zed)
endef
+define Device/ZYBO
+ $(call Device/DefaultConfig,zybo)
+endef
+
define Image/BuildKernel
$(eval $(call Device/$(PROFILE)))
$(call Image/boot-imgs)
diff --git a/target/linux/zynq/profiles/zybo.mk b/target/linux/zynq/profiles/zybo.mk
new file mode 100644
index 0000000000..dfe7e675d7
--- /dev/null
+++ b/target/linux/zynq/profiles/zybo.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZYBO
+ NAME:=ZYBO development baord
+endef
+
+define Profile/ZYBO/Description
+ Build firmware image for Digilent ZYBO development board.
+endef
+
+$(eval $(call Profile,ZYBO))