aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-12 21:44:48 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-12 21:44:48 +0000
commitf6ccd395dd5507deba988e759f621b474ec6ed70 (patch)
tree36738cce01797b24ab49d1c3b9a6a14c96f0551c /target/linux/xburst
parent3684777fc7caaf330420b52b980b6dad661362d1 (diff)
downloadmaster-187ad058-f6ccd395dd5507deba988e759f621b474ec6ed70.tar.gz
master-187ad058-f6ccd395dd5507deba988e759f621b474ec6ed70.tar.bz2
master-187ad058-f6ccd395dd5507deba988e759f621b474ec6ed70.zip
ubifs: enable building modular images
Now it is possible to build ubi/ubifs images for only selected boards inside single target. Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38375 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 9c03b38092..0de5560c96 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -10,11 +10,11 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k 512k
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBI_OPTS = -m 4096 -p 512KiB
UBIFS_OPTS = -m 4096 -e 516096 -c 4095
-UBINIZE_OPTS = -m 4096 -p 512KiB
else
+UBI_OPTS = -m 2048 -p 128KiB -s 512
UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
endif
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin