aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /target/linux/xburst
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 58436d5359..3795454c07 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -25,7 +25,7 @@ endef
define MkImageGzip
- gzip -9 -c $(1) > $(1).gz
+ gzip -9n -c $(1) > $(1).gz
mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
-e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(1).gz $(2)