aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 12:25:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 12:25:45 +0000
commitb26611b1c792e30de83561541143f9a256d41a8c (patch)
treee85e57797abb4d6c1854e841eb544a0f9c24febb /target/linux/xburst
parente8667624af01435c1858419d4acf98f0653c99b1 (diff)
downloadmaster-187ad058-b26611b1c792e30de83561541143f9a256d41a8c.tar.gz
master-187ad058-b26611b1c792e30de83561541143f9a256d41a8c.tar.bz2
master-187ad058-b26611b1c792e30de83561541143f9a256d41a8c.zip
xburst: fix imagebuilder
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45805 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 49bb254164..58436d5359 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -31,8 +31,12 @@ define MkImageGzip
-d $(1).gz $(2)
endef
+define Image/Prepare
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(KDIR)/uimage)
+endef
+
define Image/BuildKernel
- $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+ cp $(KDIR)/uimage $(UIMAGE)
endef
define Image/Build/squashfs