aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
commit9958378c233871745b6042df411f7ea8b3fa6d28 (patch)
tree249776c430feb12ac575182a62b558e500f652c4 /target/linux/xburst
parent7fef288830cda93409865932782ce493b56a4d69 (diff)
downloadmaster-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.gz
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.bz2
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.zip
image: fix jffs2(_nand) image generation
Variables dependend on JFFS2_BLOCKSIZE and NANDBLOCK_SIZE are used for template generation, so need to be present before inclusion of image.mk in target image Makefiles. So move all declarations to before any includes. Fixes: r42878 ("image.mk: clean up and parallelize mkfs calls") Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/xburst')
-rw-r--r--target/linux/xburst/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 3795454c07..0853607506 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -4,11 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k 512k
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
UBI_OPTS = -m 4096 -p 512KiB
UBIFS_OPTS = -m 4096 -e 516096 -c 4095