aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:24 +0000
commit51adeb5049eccad87f8393ae4a1d0b0984c4958a (patch)
treeed2d10fd32a10de3246e10003a67bdc5b1332f21 /target/linux/x86
parentb818c49a0a3947a1d0689336796c42afc03946ae (diff)
downloadmaster-187ad058-51adeb5049eccad87f8393ae4a1d0b0984c4958a.tar.gz
master-187ad058-51adeb5049eccad87f8393ae4a1d0b0984c4958a.tar.bz2
master-187ad058-51adeb5049eccad87f8393ae4a1d0b0984c4958a.zip
x86: add generic profiles to x86_64, kvm_guest and xen_domu
The imagebuilder requires a profile for every subtarget to work. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47421 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/64/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/kvm_guest/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/xen_domu/profiles/000-Generic.mk15
3 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/64/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/xen_domu/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))