aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2011-03-28 01:18:58 +0000
committerTravis Kemen <thepeople@openwrt.org>2011-03-28 01:18:58 +0000
commit07cbe7caa5da4fcf612574f748556a4407dc8961 (patch)
tree38d82b111f33a1918d06f9ffa842af5a10ca23fc /target/linux/x86
parent60b6ebe25618945f9d0e229ef9d981c724fefcc2 (diff)
downloadmaster-187ad058-07cbe7caa5da4fcf612574f748556a4407dc8961.tar.gz
master-187ad058-07cbe7caa5da4fcf612574f748556a4407dc8961.tar.bz2
master-187ad058-07cbe7caa5da4fcf612574f748556a4407dc8961.zip
The Geos target (and probably others, like net5501) need to grab the new cs5535 gpio driver.
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26330 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/geos/target.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
index cfeffd7427..faf616690b 100644
--- a/target/linux/x86/geos/target.mk
+++ b/target/linux/x86/geos/target.mk
@@ -1,8 +1,13 @@
BOARDNAME:=Traverse Geos
FEATURES:=squashfs jffs2 ext4 pci usb gpio
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
+ GEOS_GPIO:=gpio-cs5535-new
+else
+ GEOS_GPIO:=gpio-cs5535
+endif
DEFAULT_PACKAGES += kmod-ata-via-sata \
kmod-crypto-hw-geode kmod-crypto-ocf \
- kmod-gpio-cs5535 kmod-gpio-nsc \
+ kmod-$(GEOS_GPIO) kmod-gpio-nsc \
kmod-wdt-geode kmod-hwmon-core kmod-hwmon-lm90 \
kmod-8139cp kmod-solos-pci \
kmod-i2c-core kmod-i2c-gpio \
@@ -23,6 +28,6 @@ define Target/Description
Build firmware images for Traverse Geos board
endef
-define KernelPackage/gpio-cs5535/install
- sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535
+define KernelPackage/$(GEOS_GPIO)/install
+ sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(GEOS_GPIO)
endef