aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/rdc/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-15 18:54:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-15 18:54:34 +0000
commit86148ac69bbfb69d10b5118b6583fb0c94ede629 (patch)
tree74e95a2a02effb3010d559674ce6040bcd54f1be /target/linux/x86/rdc/profiles
parent75d227f4f8687bf9c76229cd5ecb8e72e328d05e (diff)
downloadmaster-187ad058-86148ac69bbfb69d10b5118b6583fb0c94ede629.tar.gz
master-187ad058-86148ac69bbfb69d10b5118b6583fb0c94ede629.tar.bz2
master-187ad058-86148ac69bbfb69d10b5118b6583fb0c94ede629.zip
[x86] merge the RDC R-321x target as a subtarget of x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/rdc/profiles')
-rw-r--r--target/linux/x86/rdc/profiles/ar525w.mk12
-rw-r--r--target/linux/x86/rdc/profiles/bifferboard.mk13
-rw-r--r--target/linux/x86/rdc/profiles/r8610.mk15
-rw-r--r--target/linux/x86/rdc/profiles/sitecom.mk12
4 files changed, 52 insertions, 0 deletions
diff --git a/target/linux/x86/rdc/profiles/ar525w.mk b/target/linux/x86/rdc/profiles/ar525w.mk
new file mode 100644
index 0000000000..d38cb1f232
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/ar525w.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+ NAME:=Airlink AR525W
+ PACKAGES:=kmod-rt61-pci kmod-switch-ip17xx swconfig
+endef
+$(eval $(call Profile,ar525w))
diff --git a/target/linux/x86/rdc/profiles/bifferboard.mk b/target/linux/x86/rdc/profiles/bifferboard.mk
new file mode 100644
index 0000000000..28e1d0e6d4
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/bifferboard.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/bifferboard
+ NAME:=Bifferboard
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-usb-storage kmod-scsi-core kmod-fs-ext3
+endef
+$(eval $(call Profile,bifferboard))
diff --git a/target/linux/x86/rdc/profiles/r8610.mk b/target/linux/x86/rdc/profiles/r8610.mk
new file mode 100644
index 0000000000..67fef8a5ae
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/r8610.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))
diff --git a/target/linux/x86/rdc/profiles/sitecom.mk b/target/linux/x86/rdc/profiles/sitecom.mk
new file mode 100644
index 0000000000..e3b2981ed8
--- /dev/null
+++ b/target/linux/x86/rdc/profiles/sitecom.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))