aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-3.7/011-tune_lzma_options.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-18 14:50:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-18 14:50:47 +0000
commit5843aece5007a240d022913f9bb917bdfa00d282 (patch)
tree48ec5ca85cc4ed07734b94360444fdadbdc17224 /target/linux/x86/patches-3.7/011-tune_lzma_options.patch
parentcc5e80cd6bd88e85d33d05ad993d7598d4fe829a (diff)
downloadmaster-187ad058-5843aece5007a240d022913f9bb917bdfa00d282.tar.gz
master-187ad058-5843aece5007a240d022913f9bb917bdfa00d282.tar.bz2
master-187ad058-5843aece5007a240d022913f9bb917bdfa00d282.zip
kernel: add 3.7 support for x86
Signed-off-by: David Woodhouse <David.Woodhouse@intel.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/patches-3.7/011-tune_lzma_options.patch')
-rw-r--r--target/linux/x86/patches-3.7/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/x86/patches-3.7/011-tune_lzma_options.patch b/target/linux/x86/patches-3.7/011-tune_lzma_options.patch
new file mode 100644
index 0000000000..e6fd44d4e1
--- /dev/null
+++ b/target/linux/x86/patches-3.7/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -296,7 +296,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -28,7 +28,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+