aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/legacy/profiles
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-06-25 17:57:08 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-25 17:57:08 +0200
commitd62d57ee60c752ee8909ceee2c4232f0e5964982 (patch)
tree3eea48fed6cb0ff6a25cd11f002d4ef29d0dd72c /target/linux/x86/legacy/profiles
parent102a71972771aae3b056c11288b9d7abbb5c0dea (diff)
downloadmaster-187ad058-d62d57ee60c752ee8909ceee2c4232f0e5964982.tar.gz
master-187ad058-d62d57ee60c752ee8909ceee2c4232f0e5964982.tar.bz2
master-187ad058-d62d57ee60c752ee8909ceee2c4232f0e5964982.zip
x86: reorganize x86_32 support
copy current 'generic' target to new 'legacy' target. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/x86/legacy/profiles')
-rw-r--r--target/linux/x86/legacy/profiles/000-Generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/x86/legacy/profiles/000-Generic.mk b/target/linux/x86/legacy/profiles/000-Generic.mk
new file mode 100644
index 0000000000..90f989a91d
--- /dev/null
+++ b/target/linux/x86/legacy/profiles/000-Generic.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+ kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
+ kmod-via-rhine kmod-via-velocity
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))