aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 09:59:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 09:59:56 +0000
commit4fe0549e77e309099f2c9a306798606967c3659e (patch)
tree6213e59a7f057f6ab77babb224566b2b991684bd /target/linux/x86/image
parentce44bef353e3ce217a6fa54af1256fa23dd9d7a6 (diff)
downloadmaster-187ad058-4fe0549e77e309099f2c9a306798606967c3659e.tar.gz
master-187ad058-4fe0549e77e309099f2c9a306798606967c3659e.tar.bz2
master-187ad058-4fe0549e77e309099f2c9a306798606967c3659e.zip
x86: avoid using grub prepare when using grub2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33525 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image')
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index ebe0788593..547f0839fd 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -237,7 +237,7 @@ endef
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
$(call Image/Prepare/bootscript)
- $(call Image/Prepare/grub)
+ $(call Image/Prepare/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub))
endef
define Image/Build