aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-17 19:49:25 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-17 19:49:25 +0000
commit3790ba0f38ba8c51f63c7e855b4936d6bbfa7a41 (patch)
tree1e80656993fa9491b6def9293b0f47c805dc6ada /target/linux/x86/image/Makefile
parent9be1b6cf8e78e53784efeac300d09188f6cef568 (diff)
downloadmaster-187ad058-3790ba0f38ba8c51f63c7e855b4936d6bbfa7a41.tar.gz
master-187ad058-3790ba0f38ba8c51f63c7e855b4936d6bbfa7a41.tar.bz2
master-187ad058-3790ba0f38ba8c51f63c7e855b4936d6bbfa7a41.zip
change x86 image generation handling to treat only olpc specially
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18441 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 699dcfe6ab..b412873c38 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
export PATH=$(TARGET_PATH):/sbin
-ifeq ($(CONFIG_TARGET_x86_generic),y)
+ifneq ($(CONFIG_TARGET_x86_olpc),y)
BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
#"))")) # fix vim's broken syntax highlighting
@@ -120,14 +120,13 @@ endif
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-ifeq ($(CONFIG_TARGET_x86_generic),y)
- $(call Image/Prepare/grub)
-endif
ifeq ($(CONFIG_TARGET_x86_olpc),y)
$(call Image/Prepare/bootscript)
+else
+ $(call Image/Prepare/grub)
endif
endef
-
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef