aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-28 11:37:08 +0000
commit0f6b70764ad906bb0b7ffbbba3b5db20e35ce966 (patch)
tree39a6748749415380ee3c38b27ff0a48e759f3ede /target/linux/x86/image/Makefile
parentbf7383c87c3649c652ae92d6498b725b7e54f4f2 (diff)
downloadmaster-187ad058-0f6b70764ad906bb0b7ffbbba3b5db20e35ce966.tar.gz
master-187ad058-0f6b70764ad906bb0b7ffbbba3b5db20e35ce966.tar.bz2
master-187ad058-0f6b70764ad906bb0b7ffbbba3b5db20e35ce966.zip
x86: remove the olpc subtarget, it has been unmaintained for a long time
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45083 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile34
1 files changed, 0 insertions, 34 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 85460206c0..ffda5c1578 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -100,38 +100,6 @@ endif
ROOTDELAY=10
-ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
-
- define Image/cmdline/ext4
- root=$(ROOTPART) rootfstype=ext4 rootwait
- endef
-
- define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
- endef
-
- define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
- endef
-
- define Image/Build/bootscript
- # left here because the image builder doesnt need these
- $(INSTALL_DIR) $(KDIR)/root.bootscript/boot
- $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
- sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
- ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
- PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
- $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
- $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
- endef
-
-endif
-
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -239,7 +207,6 @@ endef
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
- $(call Image/Prepare/bootscript)
$(call Image/Prepare/grub2)
endef
@@ -249,7 +216,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
- $(call Image/Build/bootscript,$(1))
ifneq ($(1),iso)
$(call Image/Build/grub2,$(1))
$(call Image/Build/vdi,$(1))