aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 17:59:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 17:59:23 +0000
commite719e0c4d9fa86ba0d0b907645c9b3dee58647e2 (patch)
treef038b16be3b85bf213dfbe6cd6682d58a5750f66 /target/linux/x86-2.6/image/Makefile
parente3b8c1fa598e2470e9c6057523dbbf959e24d78f (diff)
downloadmaster-187ad058-e719e0c4d9fa86ba0d0b907645c9b3dee58647e2.tar.gz
master-187ad058-e719e0c4d9fa86ba0d0b907645c9b3dee58647e2.tar.bz2
master-187ad058-e719e0c4d9fa86ba0d0b907645c9b3dee58647e2.zip
add optional padding for x86 grub images (useful for running jffs2 images in qemu)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image/Makefile')
-rw-r--r--target/linux/x86-2.6/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
index dc1d333434..bb7d171faf 100644
--- a/target/linux/x86-2.6/image/Makefile
+++ b/target/linux/x86-2.6/image/Makefile
@@ -44,7 +44,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(CONFIG_X86_GRUB_BOOTOPTS)#g' \
-e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
- PATH="$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/bin:$(PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/bin:$(PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
endif