aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-06 16:45:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-06 16:45:10 +0000
commit8213c44fe564a66f30fd81e72a57f1809bc2f5bf (patch)
tree306f3531837d635abeda7dc4ae51f5af04af6f49 /target/linux/uml
parentabb3836723c3b30df8c74405a691d08c521c42d4 (diff)
downloadmaster-187ad058-8213c44fe564a66f30fd81e72a57f1809bc2f5bf.tar.gz
master-187ad058-8213c44fe564a66f30fd81e72a57f1809bc2f5bf.tar.bz2
master-187ad058-8213c44fe564a66f30fd81e72a57f1809bc2f5bf.zip
[uml] add a patch to disable compile-time buffer checks enabled by default on Ubuntu 8.10 and later (closes: #4826)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15119 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml')
-rw-r--r--target/linux/uml/patches/002-gcc4_unfortify_source.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches/002-gcc4_unfortify_source.patch b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..b13e5df521
--- /dev/null
+++ b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)