aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-08-09 13:13:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-08-09 13:13:22 +0000
commit7bf9c1df4745ec7de7b17e0796186cbeeed7287f (patch)
tree34d2606279c746f4205f652ae30d5e0305196dec /target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch
parent1461ed9d45dd0c5085bece68b69c1f84b5c59801 (diff)
downloadmaster-187ad058-7bf9c1df4745ec7de7b17e0796186cbeeed7287f.tar.gz
master-187ad058-7bf9c1df4745ec7de7b17e0796186cbeeed7287f.tar.bz2
master-187ad058-7bf9c1df4745ec7de7b17e0796186cbeeed7287f.zip
[uml] update to 3.0.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch')
-rw-r--r--target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..442c0ec76e
--- /dev/null
+++ b/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+