aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-05-02 00:59:04 +0000
committerNicolas Thill <nico@openwrt.org>2010-05-02 00:59:04 +0000
commite020dc9666095d3e4a4ece481cc62d8dfd3eb5ab (patch)
tree5dbaf6f63e5f93e900b352b4746fed06ce20ddaf /target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch
parent027739a6da311d418dfae0cfe67161eec547c59a (diff)
downloadmaster-187ad058-e020dc9666095d3e4a4ece481cc62d8dfd3eb5ab.tar.gz
master-187ad058-e020dc9666095d3e4a4ece481cc62d8dfd3eb5ab.tar.bz2
master-187ad058-e020dc9666095d3e4a4ece481cc62d8dfd3eb5ab.zip
target/uml: add patches for 2.6.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21290 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch')
-rw-r--r--target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..442c0ec76e
--- /dev/null
+++ b/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+