aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6/Makefile
diff options
context:
space:
mode:
authorGerry Rozema <gerryr@rozeware.com>2006-07-20 18:42:12 +0000
committerGerry Rozema <gerryr@rozeware.com>2006-07-20 18:42:12 +0000
commitae823241fe1ab7c8c52b59b5768161935b3b5051 (patch)
tree4cdb307f80c0802781661cf57015db78612672c4 /target/linux/uml-2.6/Makefile
parentedbbc226a407a137a1167d62563ee46c521353d8 (diff)
downloadmaster-187ad058-ae823241fe1ab7c8c52b59b5768161935b3b5051.tar.gz
master-187ad058-ae823241fe1ab7c8c52b59b5768161935b3b5051.tar.bz2
master-187ad058-ae823241fe1ab7c8c52b59b5768161935b3b5051.zip
Start adding uml target
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4177 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml-2.6/Makefile')
-rwxr-xr-xtarget/linux/uml-2.6/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml-2.6/Makefile b/target/linux/uml-2.6/Makefile
new file mode 100755
index 0000000000..59f02b3340
--- /dev/null
+++ b/target/linux/uml-2.6/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+ @$(CP) config $(LINUX_DIR)/.config
+ touch $@