aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ubicom32/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-21 22:32:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-21 22:32:31 +0000
commit14dde50efd4eb00edb2ae3f2b8ac1b2ed09604c4 (patch)
treed01d05b694c1dfcde7b1e9873adbeeb1b8a56809 /target/linux/ubicom32/Makefile
parent745afea5dd28434c02647e666fc8c11aaff44fed (diff)
downloadmaster-187ad058-14dde50efd4eb00edb2ae3f2b8ac1b2ed09604c4.tar.gz
master-187ad058-14dde50efd4eb00edb2ae3f2b8ac1b2ed09604c4.tar.bz2
master-187ad058-14dde50efd4eb00edb2ae3f2b8ac1b2ed09604c4.zip
add a new target for ubicom32 (compiles, but untested)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ubicom32/Makefile')
-rw-r--r--target/linux/ubicom32/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ubicom32/Makefile b/target/linux/ubicom32/Makefile
new file mode 100644
index 0000000000..7bdbd204e8
--- /dev/null
+++ b/target/linux/ubicom32/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+#Add target specific (nommu) flags
+TARGET_CFLAGS+= -DNO_FORK
+
+ARCH:=ubicom32
+BOARD:=ubicom32
+BOARDNAME:=Ubicom IPxx
+FEATURES:=nommu
+
+LINUX_VERSION:=2.6.28.10
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNEL_MAKEOPTS += LDFLAGS_BUILD_ID=""
+
+define Target/Description
+ Build firmware images for Ubicom based routers and media devices.
+endef
+
+$(eval $(call BuildTarget))