aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-08-21 13:16:11 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-08-21 13:16:11 +0000
commit6bb2c0385c71c8ed4e512203b2bc53fcce6b6c66 (patch)
tree700f20634e94e726173d1a5f3542bcd5a2c9ebb4 /target/linux/sunxi
parent61722dc82cea1096e115e96461481e40f8d6b59c (diff)
downloadmaster-187ad058-6bb2c0385c71c8ed4e512203b2bc53fcce6b6c66.tar.gz
master-187ad058-6bb2c0385c71c8ed4e512203b2bc53fcce6b6c66.tar.bz2
master-187ad058-6bb2c0385c71c8ed4e512203b2bc53fcce6b6c66.zip
sunxi: add audio module for 4.1
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46704 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 0981fe553f..3e8f4ba71a 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -100,3 +100,20 @@ endef
$(eval $(call KernelPackage,wdt-sunxi))
+
+define KernelPackage/sound-soc-sunxi
+ TITLE:=AllWinner built-in SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_SUNXI_SOC_CODEC
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/sunxi/sunxi-codec.ko
+ AUTOLOAD:=$(call AutoLoad,65,sunxi-codec)
+ DEPENDS:=@TARGET_sunxi +kmod-sound-soc-core @LINUX_4_1
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-sunxi/description
+ Kernel support for AllWinner built-in SoC audio
+endef
+
+$(eval $(call KernelPackage,sound-soc-sunxi))