aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2015-08-21 10:08:07 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2015-08-21 10:08:07 +0000
commit09402e46b285c66fdcd3fbb415892cb392e12714 (patch)
treebfb6d3ffa4cd136906ee53c267a271de51790bc2 /target/linux/sunxi
parentd5df4f1e5e61330395434eed6c15bfe19507bb33 (diff)
downloadmaster-187ad058-09402e46b285c66fdcd3fbb415892cb392e12714.tar.gz
master-187ad058-09402e46b285c66fdcd3fbb415892cb392e12714.tar.bz2
master-187ad058-09402e46b285c66fdcd3fbb415892cb392e12714.zip
sunxi: reorganize kmod-ata-sunxi dependencies
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46702 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index a4c71b9b86..0981fe553f 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -61,10 +61,8 @@ $(eval $(call KernelPackage,eeprom-sunxi))
define KernelPackage/ata-sunxi
TITLE:=AllWinner sunXi AHCI SATA support
SUBMENU:=$(BLOCK_MENU)
- DEPENDS:=@TARGET_sunxi +kmod-scsi-core
- KCONFIG:=\
- CONFIG_AHCI_SUNXI \
- CONFIG_SATA_AHCI_PLATFORM
+ DEPENDS:=@TARGET_sunxi +kmod-ata-ahci-platform +kmod-scsi-core
+ KCONFIG:=CONFIG_AHCI_SUNXI
FILES:=$(LINUX_DIR)/drivers/ata/ahci_sunxi.ko
AUTOLOAD:=$(call AutoLoad,41,ahci_sunxi,1)
endef