aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:06:33 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:06:33 +0000
commit098f187e7870684bfaaa53a1fdfc9682cc1e0dae (patch)
treee4f67db9483b1ce0d774fc67ab46a18171579338 /target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch
parentbbf13d61b7377b5114d9c716b7326f3f2bc468c1 (diff)
downloadmaster-187ad058-098f187e7870684bfaaa53a1fdfc9682cc1e0dae.tar.gz
master-187ad058-098f187e7870684bfaaa53a1fdfc9682cc1e0dae.tar.bz2
master-187ad058-098f187e7870684bfaaa53a1fdfc9682cc1e0dae.zip
kernel: update 4.1 to 4.1.5
Changelog: * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.5 Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch')
-rw-r--r--target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch b/target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch
index ea1e100a06..471fb2ad6e 100644
--- a/target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch
+++ b/target/linux/sunxi/patches-4.1/160-dmaengine-add-sun4i-driver.patch
@@ -55,9 +55,6 @@ Changes from v1:
create mode 100644 Documentation/devicetree/bindings/dma/sun4i-dma.txt
create mode 100644 drivers/dma/sun4i-dma.c
-diff --git a/Documentation/devicetree/bindings/dma/sun4i-dma.txt b/Documentation/devicetree/bindings/dma/sun4i-dma.txt
-new file mode 100644
-index 0000000..f1634a2
--- /dev/null
+++ b/Documentation/devicetree/bindings/dma/sun4i-dma.txt
@@ -0,0 +1,46 @@
@@ -107,11 +104,9 @@ index 0000000..f1634a2
+ #address-cells = <1>;
+ #size-cells = <0>;
+ };
-diff --git a/drivers/dma/Kconfig b/drivers/dma/Kconfig
-index fd7ac13..12372c2 100644
--- a/drivers/dma/Kconfig
+++ b/drivers/dma/Kconfig
-@@ -443,6 +443,17 @@ config XGENE_DMA
+@@ -444,6 +444,17 @@ config XGENE_DMA
help
Enable support for the APM X-Gene SoC DMA engine.
@@ -129,8 +124,6 @@ index fd7ac13..12372c2 100644
config DMA_ENGINE
bool
-diff --git a/drivers/dma/Makefile b/drivers/dma/Makefile
-index 69f77d5..3eba5e9 100644
--- a/drivers/dma/Makefile
+++ b/drivers/dma/Makefile
@@ -54,3 +54,4 @@ obj-$(CONFIG_NBPFAXI_DMA) += nbpfaxi.o
@@ -138,9 +131,6 @@ index 69f77d5..3eba5e9 100644
obj-$(CONFIG_IMG_MDC_DMA) += img-mdc-dma.o
obj-$(CONFIG_XGENE_DMA) += xgene-dma.o
+obj-$(CONFIG_SUN4I_DMA) += sun4i-dma.o
-diff --git a/drivers/dma/sun4i-dma.c b/drivers/dma/sun4i-dma.c
-new file mode 100644
-index 0000000..a8d55518
--- /dev/null
+++ b/drivers/dma/sun4i-dma.c
@@ -0,0 +1,1235 @@