aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realview
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 15:34:38 +0000
commita9a54d6b5b055a3af8648cbf603e4f0192951c55 (patch)
tree79d671ebcd4d032719c8ed1dc0a1661275a3613b /target/linux/realview
parent46233366472c5384b3c82a49b04d0398b0297385 (diff)
downloadmaster-187ad058-a9a54d6b5b055a3af8648cbf603e4f0192951c55.tar.gz
master-187ad058-a9a54d6b5b055a3af8648cbf603e4f0192951c55.tar.bz2
master-187ad058-a9a54d6b5b055a3af8648cbf603e4f0192951c55.zip
realview: use common image prefix
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45787 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/realview')
-rw-r--r--target/linux/realview/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index 1f3fa4a664..28db6f330c 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
endef
define Image/BuildKernel/Initramfs
- cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
+ cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs
@@ -21,7 +21,7 @@ endef
define Image/Build
$(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))