aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realview
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 20:17:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 20:17:19 +0000
commit0a602b2b72aed043e3229667d4ced72a8059eda5 (patch)
tree70a5f272a53f8114dd1f35f9199324d95da32cf1 /target/linux/realview
parent40935a16aae0b254b359065c43bbf1f7edda4b6b (diff)
downloadmaster-187ad058-0a602b2b72aed043e3229667d4ced72a8059eda5.tar.gz
master-187ad058-0a602b2b72aed043e3229667d4ced72a8059eda5.tar.bz2
master-187ad058-0a602b2b72aed043e3229667d4ced72a8059eda5.zip
targets: remove useless quotes around KERNELNAME
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42780 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/realview')
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/realview/image/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 3d49605130..80892075b0 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -24,6 +24,6 @@ define Target/Description
Build images for ARM Ltd. Realview boards to be run with qemu
endef
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
$(eval $(call BuildTarget))
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index c6ff8ce46a..1f3fa4a664 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
endef
define Image/BuildKernel/Initramfs
- cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
+ cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs