aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-12-13 00:02:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-12-13 00:02:29 +0000
commitf5b4efa8e684670b76eca0edb38c6527bf1a437c (patch)
treef66c47e1dcb1408601bda1994dca26765ffe4151 /target/linux/rdc
parent2387421e7278053f347507ac6826ba581277c06e (diff)
downloadmaster-187ad058-f5b4efa8e684670b76eca0edb38c6527bf1a437c.tar.gz
master-187ad058-f5b4efa8e684670b76eca0edb38c6527bf1a437c.tar.bz2
master-187ad058-f5b4efa8e684670b76eca0edb38c6527bf1a437c.zip
[rdc] generate bifferboard images, patch from bifferos
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18768 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc')
-rw-r--r--target/linux/rdc/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index f8082b08d5..9b4c13508b 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -84,6 +84,11 @@ define Image/Build/amit
$(STAGING_DIR_HOST)/bin/makeamitbin -o $(BIN_DIR)/openwrt-$(BOARD)-$(1)-ar360w3g.bin -1 ALK_ATG001 -2 Atropos linux3g $(KDIR)/bzImage ramdisk3g $(KDIR)/root.$(1)
endef
+define Image/Build/bifferboard
+ $(TOPDIR)/target/linux/rdc/image/mkimg_bifferboard.py $(KDIR)/bzImage $(KDIR)/root.$(1) $(KDIR)/tmp.img
+ $(CP) $(KDIR)/tmp.img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+endef
+
define Image/Build/Initramfs
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-ramfs.bzImage
endef