aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-05 13:38:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-05 13:38:19 +0000
commit2b7ce0aaed2405b68684c9f91c9e519f17d331f1 (patch)
tree6957ed01700a4e24139fd3f3867ba20d4773afd6 /target/linux/rdc
parent12fb2d89b47a5004e00eb6fea320ea787fef860f (diff)
downloadmaster-187ad058-2b7ce0aaed2405b68684c9f91c9e519f17d331f1.tar.gz
master-187ad058-2b7ce0aaed2405b68684c9f91c9e519f17d331f1.tar.bz2
master-187ad058-2b7ce0aaed2405b68684c9f91c9e519f17d331f1.zip
If the *.img file is larger than 0x1e8000 loading it with
flash -s 0x100000 -d 0xffe08000 -l <length> on the bootloader prompt will destroy the bootloader and brick the device. The attached patch tries to implement a size check and renames the image into *.img.too_big. It applies to svn r11401. Signed-off-by: Joerg Albert <jal2@gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11662 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc')
-rw-r--r--target/linux/rdc/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index a8ad099668..f1fed220e7 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -47,6 +47,7 @@ define Image/Build/wl153
echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1).gz >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
$(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
+ if [ `ls -l $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/'` -gt $$$$((0xffff0000-0xffe08000)) ]; then mv $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img.too_big; echo "#ERR image too big"; fi
endef
define Image/Build/dir450