aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-10-28 18:54:35 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-10-28 18:54:35 +0000
commit650ecd8f3dd25d225f876f4961cb26745a2f2b68 (patch)
treedd9bfdf24ba459971f6f6bda63de236af89a0db8 /target/linux/rdc/profiles
parent8863cdb3e6de6917ddbb2e70e2f3452d45a98395 (diff)
downloadmaster-187ad058-650ecd8f3dd25d225f876f4961cb26745a2f2b68.tar.gz
master-187ad058-650ecd8f3dd25d225f876f4961cb26745a2f2b68.tar.bz2
master-187ad058-650ecd8f3dd25d225f876f4961cb26745a2f2b68.zip
Update kernel configuration and add profiles and per-profile kernel configuration files for AMIT and Zyxel boards, thanks sn9
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13064 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc/profiles')
-rw-r--r--target/linux/rdc/profiles/AMIT.mk13
-rw-r--r--target/linux/rdc/profiles/G-570S.mk13
2 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/AMIT.mk b/target/linux/rdc/profiles/AMIT.mk
new file mode 100644
index 0000000000..2e3d873847
--- /dev/null
+++ b/target/linux/rdc/profiles/AMIT.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/amit
+ NAME:=Devices from AMIT
+ PACKAGES:=kmod-r6040 kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,amit))
+
diff --git a/target/linux/rdc/profiles/G-570S.mk b/target/linux/rdc/profiles/G-570S.mk
new file mode 100644
index 0000000000..4cb9bd9a94
--- /dev/null
+++ b/target/linux/rdc/profiles/G-570S.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/g570s
+ NAME:=ZyXEL G-570S
+ PACKAGES:=kmod-madwifi kmod-r6040
+endef
+$(eval $(call Profile,g570s))
+